#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^P(?:(?P<years>[0-9\.]+)Y)?(?:(?P<months>[0-9\.]+)M)?(?:(?P<days>[0-9\.]+)D)?(?P<time>T(?:(?P<hours>[0-9\.]+)H)?(?:(?P<minutes>[0-9\.]+)M)?(?:(?P<seconds>[0-9\.]+)S)?)?$"
Local $sString = "P1Y2M3DT4H5M6.007S" & @CRLF & _
"PT12H" & @CRLF & _
"PT12.007S"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)