$re = '/^P(?:(?P<years>[0-9\.]+)Y)?(?:(?P<months>[0-9\.]+)M)?(?:(?P<days>[0-9\.]+)D)?(?P<time>T(?:(?P<hours>[0-9\.]+)H)?(?:(?P<minutes>[0-9\.]+)M)?(?:(?P<seconds>[0-9\.]+)S)?)?$/m';
$str = 'P1Y2M3DT4H5M6.007S
PT12H
PT12.007S';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;