// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^P(?:(?P<years>[0-9\.]+)Y)?(?:(?P<months>[0-9\.]+)M)?(?:(?P<days>[0-9\.]+)D)?(?P<time>T(?:(?P<hours>[0-9\.]+)H)?(?:(?P<minutes>[0-9\.]+)M)?(?:(?P<seconds>[0-9\.]+)S)?)?$").unwrap();
let string = "P1Y2M3DT4H5M6.007S
PT12H
PT12.007S";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}