import re
regex = re.compile(r"^P(?:(?P<years>[0-9\.]+)Y)?(?:(?P<months>[0-9\.]+)M)?(?:(?P<days>[0-9\.]+)D)?(?P<time>T(?:(?P<hours>[0-9\.]+)H)?(?:(?P<minutes>[0-9\.]+)M)?(?:(?P<seconds>[0-9\.]+)S)?)?$", flags=re.MULTILINE)
test_str = ("P1Y2M3DT4H5M6.007S\n"
"PT12H\n"
"PT12.007S")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)