#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(abc?\.com/(test/)?[\.a-zA-Z\d]+(/title/\d{5}))"
Local $sString = "'abc.ru/v2', 'abc.com/er.tyre.6/title/86348', 'ab.com/test/ertg.yeg/title/86348', 'abc.com/feed?app_id=57655', 'bcd.ru/467', 'abc.com/shth/5583628', 'abc.com/jhydhf'"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")