$re = '/(abc?\.com/(test/)?[\.a-zA-Z\d]+(/title/\d{5}))/m';
$str = '\'abc.ru/v2\', \'abc.com/er.tyre.6/title/86348\', \'ab.com/test/ertg.yeg/title/86348\', \'abc.com/feed?app_id=57655\', \'bcd.ru/467\', \'abc.com/shth/5583628\', \'abc.com/jhydhf\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);