re = /(abc?\.com\/(test\/)?[\.a-zA-Z\d]+(\/title\/\d{5}))/m
str = '\'abc.ru/v2\', \'abc.com/er.tyre.6/title/86348\', \'ab.com/test/ertg.yeg/title/86348\', \'abc.com/feed?app_id=57655\', \'bcd.ru/467\', \'abc.com/shth/5583628\', \'abc.com/jhydhf\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end