using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(abc?\.com/(test/)?[\.a-zA-Z\d]+(/title/\d{5}))";
string input = @"'abc.ru/v2', 'abc.com/er.tyre.6/title/86348', 'ab.com/test/ertg.yeg/title/86348', 'abc.com/feed?app_id=57655', 'bcd.ru/467', 'abc.com/shth/5583628', 'abc.com/jhydhf'";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}