const regex = new RegExp('(abc?\\.com/(test/)?[\\.a-zA-Z\\d]+(/title/\\d{5}))', 'gm')
const str = `'abc.ru/v2', 'abc.com/er.tyre.6/title/86348', 'ab.com/test/ertg.yeg/title/86348', 'abc.com/feed?app_id=57655', 'bcd.ru/467', 'abc.com/shth/5583628', 'abc.com/jhydhf'`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}