# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\/[^\/]*\///gm;t' <<< "/en/joe-doe/contact
/somedynamic string/joe-doe/contact"