#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^/[^/]*/"
Local $sString = "/en/joe-doe/contact" & @CRLF & _
"/somedynamic string/joe-doe/contact"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)