use strict;
my $str = '/en/joe-doe/contact
/somedynamic string/joe-doe/contact';
my $regex = qr~^/[^/]*/~mp;
my $subst = '';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";