$re = '~^/[^/]*/~m';
$str = '/en/joe-doe/contact
/somedynamic string/joe-doe/contact';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;