const regex = new RegExp('^/[^/]*/', 'gm')
const str = `/en/joe-doe/contact
/somedynamic string/joe-doe/contact`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);