package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[a-zA-Z_0-9]+@[a-zA-Z._]+\.[a-zA-Z_]{2,3}+`)
var str = `holahohd8@gmail.com
comoestahdh778@outlook.com.mxmhola83h_0@gmail.com mOND@jshd.com h0lwj_jsi@outlook.mx.com 6_@gfd.com hjh
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}