import Foundation
let pattern = #"[a-zA-Z_0-9]+@[a-zA-Z._]+\.[a-zA-Z_]{2,3}+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
holahohd8@gmail.com
comoestahdh778@outlook.com.mxmhola83h_0@gmail.com mOND@jshd.com h0lwj_jsi@outlook.mx.com 6_@gfd.com hjh
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)