$re = '/[a-zA-Z_0-9]+@[a-zA-Z._]+\.[a-zA-Z_]{2,3}+/m';
$str = 'holahohd8@gmail.com
comoestahdh778@outlook.com.mxmhola83h_0@gmail.com mOND@jshd.com h0lwj_jsi@outlook.mx.com 6_@gfd.com hjh
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);