const regex = /[a-zA-Z_0-9]+@[a-zA-Z._]+\.[a-zA-Z_]{2,3}+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[a-zA-Z_0-9]+@[a-zA-Z._]+\\.[a-zA-Z_]{2,3}+', 'gm')
const str = `holahohd8@gmail.com
comoestahdh778@outlook.com.mxmhola83h_0@gmail.com mOND@jshd.com h0lwj_jsi@outlook.mx.com 6_@gfd.com hjh
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}