import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[a-zA-Z_0-9]+@[a-zA-Z._]+\\.[a-zA-Z_]{2,3}+";
final String string = "holahohd8@gmail.com\n"
+ "comoestahdh778@outlook.com.mxmhola83h_0@gmail.com mOND@jshd.com h0lwj_jsi@outlook.mx.com 6_@gfd.com hjh\n\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}