#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)Thread\s*\.\s*sleep\s*\(\s*\d+\s*\)"
Local $sString = "Thread.sleep(1000)" & @CRLF & _
"" & @CRLF & _
"Thread" & @CRLF & _
".sleep(1000)" & @CRLF & _
"" & @CRLF & _
"Thread.sleep( 1000 )" & @CRLF & _
"" & @CRLF & _
"Thread . sleep( 1000 )"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")