$re = '/Thread\s*\.\s*sleep\s*\(\s*\d+\s*\)/m';
$str = 'Thread.sleep(1000)
Thread
.sleep(1000)
Thread.sleep( 1000 )
Thread . sleep( 1000 )';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);