re = /Thread\s*\.\s*sleep\s*\(\s*\d+\s*\)/m
str = 'Thread.sleep(1000)
Thread
.sleep(1000)
Thread.sleep( 1000 )
Thread . sleep( 1000 )'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end