package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Thread\s*\.\s*sleep\s*\(\s*\d+\s*\)`)
var str = `Thread.sleep(1000)
Thread
.sleep(1000)
Thread.sleep( 1000 )
Thread . sleep( 1000 )`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}