using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Thread\s*\.\s*sleep\s*\(\s*\d+\s*\)";
string input = @"Thread.sleep(1000)
Thread
.sleep(1000)
Thread.sleep( 1000 )
Thread . sleep( 1000 )";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}