#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^-?(?!0\d)\d+\.?\d*$"
Local $sString = "0.500" & @CRLF & _
"3" & @CRLF & _
"0" & @CRLF & _
"0.0" & @CRLF & _
"30" & @CRLF & _
"0." & @CRLF & _
"500000" & @CRLF & _
"4000.22" & @CRLF & _
"0.50" & @CRLF & _
"" & @CRLF & _
".3" & @CRLF & _
".44" & @CRLF & _
"00" & @CRLF & _
"00.5" & @CRLF & _
"03.3" & @CRLF & _
"00" & @CRLF & _
"02" & @CRLF & _
"00.0" & @CRLF & _
"03" & @CRLF & _
"-03" & @CRLF & _
"-01" & @CRLF & _
"-01." & @CRLF & _
"0004"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")