using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^-?(?!0\d)\d+\.?\d*$";
string input = @"0.500
3
0
0.0
30
0.
500000
4000.22
0.50
.3
.44
00
00.5
03.3
00
02
00.0
03
-03
-01
-01.
0004";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}