use strict;
my $str = '0.500
3
0
0.0
30
0.
500000
4000.22
0.50
.3
.44
00
00.5
03.3
00
02
00.0
03
-03
-01
-01.
0004';
my $regex = qr/^-?(?!0\d)\d+\.?\d*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}