using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\{(?:(?:\{(?:(?:\{(?:[^{}])*\})|(?:[^{}]))*\})|(?:[^{}]))*\}";
string input = @"captures up to singly-nested blocks:
p{1} = \{(?:[^{}])*\}
int main() {
return 0;
}
captures up to doubly-nested:
p{2} = \{(?:(?:p{1})|(?:[^{}]))*\}
...or...
p{2} = \{(?:(?:\{(?:[^{}])*\})|(?:[^{}]))*\}
void more_complex_fxn(int z) {
int x = z / 9;
if (x > 3) {
do_something;
x += 5;
}
}
Following the pattern set above...
up to triply-nested:
p{3} = \{(?:(?:p{2})|(?:[^{}]))*\}
...or...
p{3} = \{(?:(?:\{(?:(?:\{(?:[^{}])*\})|(?:[^{}]))*\})|(?:[^{}]))*\}
double so_many_blocks(double x) {
double y = x;
while(y > 4) {
if (y < 6) {
y -= 0.3;
} else {
y -= 0.5;
}
}
return y;
}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}