$re = '/\{(?:(?:\{(?:(?:\{(?:[^{}])*\})|(?:[^{}]))*\})|(?:[^{}]))*\}/';
$str = 'captures up to singly-nested blocks:
p{1} = \\{(?:[^{}])*\\}
int main() {
return 0;
}
captures up to doubly-nested:
p{2} = \\{(?:(?:p{1})|(?:[^{}]))*\\}
...or...
p{2} = \\{(?:(?:\\{(?:[^{}])*\\})|(?:[^{}]))*\\}
void more_complex_fxn(int z) {
int x = z / 9;
if (x > 3) {
do_something;
x += 5;
}
}
Following the pattern set above...
up to triply-nested:
p{3} = \\{(?:(?:p{2})|(?:[^{}]))*\\}
...or...
p{3} = \\{(?:(?:\\{(?:(?:\\{(?:[^{}])*\\})|(?:[^{}]))*\\})|(?:[^{}]))*\\}
double so_many_blocks(double x) {
double y = x;
while(y > 4) {
if (y < 6) {
y -= 0.3;
} else {
y -= 0.5;
}
}
return y;
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);