# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\{(?:(?:\{(?:(?:\{(?:[^{}])*\})|(?:[^{}]))*\})|(?:[^{}]))*\}"
test_str = ("captures up to singly-nested blocks:\n"
" p{1} = \\{(?:[^{}])*\\}\n\n\n"
"int main() {\n\n"
" return 0;\n\n"
"}\n\n"
"captures up to doubly-nested:\n"
" p{2} = \\{(?:(?:p{1})|(?:[^{}]))*\\}\n"
" ...or...\n"
" p{2} = \\{(?:(?:\\{(?:[^{}])*\\})|(?:[^{}]))*\\}\n\n"
"void more_complex_fxn(int z) {\n"
" int x = z / 9;\n"
" if (x > 3) {\n"
" do_something;\n"
" x += 5;\n"
" }\n\n"
"}\n\n"
"Following the pattern set above...\n\n"
"up to triply-nested:\n"
" p{3} = \\{(?:(?:p{2})|(?:[^{}]))*\\}\n"
" ...or...\n"
" p{3} = \\{(?:(?:\\{(?:(?:\\{(?:[^{}])*\\})|(?:[^{}]))*\\})|(?:[^{}]))*\\}\n\n"
"double so_many_blocks(double x) {\n"
" double y = x;\n"
" while(y > 4) {\n"
" if (y < 6) {\n"
" y -= 0.3;\n"
" } else {\n"
" y -= 0.5;\n"
" }\n"
" }\n"
" return y;\n"
"}")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.