import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{(?:(?:\\{(?:(?:\\{(?:[^\\{\\}])*\\})|(?:[^\\{\\}]))*\\})|(?:[^\\{\\}]))*\\}";
final String string = "captures up to singly-nested blocks:\n"
+ " p{1} = \\{(?:[^{}])*\\}\n\n\n"
+ "int main() {\n\n"
+ " return 0;\n\n"
+ "}\n\n"
+ "captures up to doubly-nested:\n"
+ " p{2} = \\{(?:(?:p{1})|(?:[^{}]))*\\}\n"
+ " ...or...\n"
+ " p{2} = \\{(?:(?:\\{(?:[^{}])*\\})|(?:[^{}]))*\\}\n\n"
+ "void more_complex_fxn(int z) {\n"
+ " int x = z / 9;\n"
+ " if (x > 3) {\n"
+ " do_something;\n"
+ " x += 5;\n"
+ " }\n\n"
+ "}\n\n"
+ "Following the pattern set above...\n\n"
+ "up to triply-nested:\n"
+ " p{3} = \\{(?:(?:p{2})|(?:[^{}]))*\\}\n"
+ " ...or...\n"
+ " p{3} = \\{(?:(?:\\{(?:(?:\\{(?:[^{}])*\\})|(?:[^{}]))*\\})|(?:[^{}]))*\\}\n\n"
+ "double so_many_blocks(double x) {\n"
+ " double y = x;\n"
+ " while(y > 4) {\n"
+ " if (y < 6) {\n"
+ " y -= 0.3;\n"
+ " } else {\n"
+ " y -= 0.5;\n"
+ " }\n"
+ " }\n"
+ " return y;\n"
+ "}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}