#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!\/(?:audio|video)\/?$).+[A-Z].*"
Local $sString = "/audio" & @CRLF & _
"/video" & @CRLF & _
"/eLmO" & @CRLF & _
"/audio/" & @CRLF & _
"/video/" & @CRLF & _
"/audio/test" & @CRLF & _
"/video/test/test" & @CRLF & _
"" & @CRLF & _
"/audio-HELP" & @CRLF & _
"/elmo/Elmo/Elmo" & @CRLF & _
"/elmo/elmo/elmo" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")