import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!\\/(?:audio|video)\\/?$).+[A-Z].*";
final String string = "/audio\n"
+ "/video\n"
+ "/eLmO\n"
+ "/audio/\n"
+ "/video/\n"
+ "/audio/test\n"
+ "/video/test/test\n\n"
+ "/audio-HELP\n"
+ "/elmo/Elmo/Elmo\n"
+ "/elmo/elmo/elmo\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}