using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!\/(?:audio|video)\/?$).+[A-Z].*";
string input = @"/audio
/video
/eLmO
/audio/
/video/
/audio/test
/video/test/test
/audio-HELP
/elmo/Elmo/Elmo
/elmo/elmo/elmo
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}