import re
regex = re.compile(r"^(?!\/(?:audio|video)\/?$).+[A-Z].*", flags=re.MULTILINE)
test_str = ("/audio\n"
"/video\n"
"/eLmO\n"
"/audio/\n"
"/video/\n"
"/audio/test\n"
"/video/test/test\n\n"
"/audio-HELP\n"
"/elmo/Elmo/Elmo\n"
"/elmo/elmo/elmo\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")