using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"0*(\d{2,3})_\d";
string input = @"ZATR0008_2018.pdf
ZATR0018_2018.pdf
ZATR0218_2018.pdf";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}