// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)0*(\d{2,3})_\d").unwrap();
let string = "ZATR0008_2018.pdf
ZATR0018_2018.pdf
ZATR0218_2018.pdf";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}