package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)0*(\d{2,3})_\d`)
var str = `ZATR0008_2018.pdf
ZATR0018_2018.pdf
ZATR0218_2018.pdf`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}