const regex = /0*(\d{2,3})_\d/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('0*(\\d{2,3})_\\d', 'gm')
const str = `ZATR0008_2018.pdf
ZATR0018_2018.pdf
ZATR0218_2018.pdf`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}