re = /0*(\d{2,3})_\d/m
str = 'ZATR0008_2018.pdf
ZATR0018_2018.pdf
ZATR0218_2018.pdf'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end