#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(-?\d*)[.,](\d*)° [NS], (-?\d*)[.,](\d*)° [EOW]"
Local $sString = "38,89016° N, 1,22427° O" & @CRLF & _
"38.89016° N, 1.22427° E" & @CRLF & _
"-38.89016° S, 1.22427° E" & @CRLF & _
"Address: Some street, 123, 21" & @CRLF & _
""
Local $sSubst = "$1.$2, $3.$4"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)