const regex = /(-?\d*)[.,](\d*)° [NS], (-?\d*)[.,](\d*)° [EOW]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(-?\\d*)[.,](\\d*)° [NS], (-?\\d*)[.,](\\d*)° [EOW]', 'gm')
const str = `38,89016° N, 1,22427° O
38.89016° N, 1.22427° E
-38.89016° S, 1.22427° E
Address: Some street, 123, 21
`;
const subst = `$1.$2, $3.$4`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);