$re = '/(-?\d*)[.,](\d*)° [NS], (-?\d*)[.,](\d*)° [EOW]/m';
$str = '38,89016° N, 1,22427° O
38.89016° N, 1.22427° E
-38.89016° S, 1.22427° E
Address: Some street, 123, 21
';
$subst = "$1.$2, $3.$4";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;