using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(-?\d*)[.,](\d*)° [NS], (-?\d*)[.,](\d*)° [EOW]";
string substitution = @"$1.$2, $3.$4";
string input = @"38,89016° N, 1,22427° O
38.89016° N, 1.22427° E
-38.89016° S, 1.22427° E
Address: Some street, 123, 21
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}