import re
regex = re.compile(r"(-?\d*)[.,](\d*)° [NS], (-?\d*)[.,](\d*)° [EOW]", flags=re.MULTILINE)
test_str = ("38,89016° N, 1,22427° O\n"
"38.89016° N, 1.22427° E\n"
"-38.89016° S, 1.22427° E\n"
"Address: Some street, 123, 21\n")
subst = "$1.$2, $3.$4"
result = regex.sub(subst, test_str)
if result:
print(result)