#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "@([\w\d]+)"
Local $sString = "@asg7fdh"
Local $sSubst = "<a>$1</a>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)