using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"@([\w\d]+)";
string substitution = @"<a>$1</a>";
string input = @"@asg7fdh";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}