$re = '/@([\w\d]+)/';
$str = '@asg7fdh';
$subst = "<a>$1</a>";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;