// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"@([\w\d]+)").unwrap();
let string = "@asg7fdh";
let substitution = "<a>$1</a>";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}