use strict;
my $str = '@asg7fdh';
my $regex = qr/@([\w\d]+)/p;
my $subst = '<a>$1</a>';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";